8451
Comment:
|
8561
|
Deletions are marked like this. | Additions are marked like this. |
Line 13: | Line 13: |
* AMEU '''Wednesday 14-Oct-2009 1500 UTC - 1545 UTC''' * Asia``Pac '''Wednesday 07-Oct-2009 2100 UTC - 2145 UTC''' |
* AMEU '''Wednesday 06-Jan-2010 1500 UTC - 1545 UTC''' * Asia``Pac '''Wednesday 06-Jan-2010 2100 UTC - 2145 UTC''' |
Line 23: | Line 23: |
* UI review call update * Careful with those drive-bys, they make reviewing unnecessarily harder [intellectronica] * How can we better incorporate drive-bys and other tech debt payoff into our development process? [barry] * Noodles and I (Edwin) discovered that we were using different guidelines for what goes into the view.label property. * My method reduces the amount of redundancy between the <h1> and the breadcrumbs directly below it. For example: || '''Define upstream link''' <<BR>> Ubuntu >> 9.04 >> “mozilla-firefox” source package >> Define upstream link || * Noodle's method could have better google foo, since it puts more relevant info in the <h1>. For example: || '''Define upstream link for mozilla-firefox in Ubuntu Jaunty''' <<BR>> Ubuntu >> 9.04 >> “mozilla-firefox” source package >> Define upstream link || |
* invite other teams to do lazr-js code reviews? [mars/barry] |
Line 41: | Line 34: |
* gary_poster and barry will transfer review guidelines from the old wiki and old old wiki to the new wiki | * intellectronica and barry to draft guidelines for drive-by cleanups |
Line 47: | Line 40: |
* ''yourtopic [yourname]'' |
* Reminder: Who can do JS reviews? All reviewers? [henninge,allenap] * Proposed coding standard for YUI modules. [Edwin] * I think a file such as lib/canonical/launchpad/javascript/'''registry/timeline'''.js should define its module like this: {{{ YUI().add('registry.timeline', function (Y) { var module = Y.namespace('registry.timeline'); module.someFunction = function() {}; }); }}} * Then, the code could be accessed with: {{{ YUI().use('registry.timeline', function(Y) { Y.registry.timeline.someFunction(); }); }}} * The [[JavaScriptReviewNotes#Namespaces|javascript style guide]] doesn't specify how modules should be named currently. * [[https://pastebin.canonical.com/25818/|Current inconsistencies]] * Cleaning up outstanding '''approved''' branches on [[https://code.edge.launchpad.net/launchpad/+activereviews| +activereviews]], bac * ''your item [your name]'' |
Line 53: | Line 61: |
* [[ReviewerMeeting20091125]] * [[ReviewerMeeting20091014]] |
Agenda of the next Launchpad review team meeting
Launchpad review team meetings are held on #launchpad-meeting on irc.freenode.net, and are chaired by BarryWarsaw for both the Asia/Pacific (AsiaPac) and Americas/EU (AMEU) time zone meetings. We use MootBot to record the meetings.
The purpose of the meetings is to coordinate Launchpad code reviews, and particularly to ensure that emerging issues with the review process are addressed - such as getting people to take on tough reviews, keeping the latency down, etc.. Blockage in reviews leads to blockage in Launchpad code landings.
The next Launchpad review team meeting will be held at this time:
AMEU Wednesday 06-Jan-2010 1500 UTC - 1545 UTC
AsiaPac Wednesday 06-Jan-2010 2100 UTC - 2145 UTC
You can add new items to the list of proposed items. If they don't make it onto this meetings agenda, they'll most likely get onto the next meeting's agenda instead.
Agenda
- Roll call
- Action items
- invite other teams to do lazr-js code reviews? [mars/barry]
- Peanut gallery (anything not on the agenda)
Apologies
Please include the date for which you will be unavailable.
yourname, date
Outstanding Actions
- intellectronica and barry to draft guidelines for drive-by cleanups
Notes
Proposed items
- Reminder: Who can do JS reviews? All reviewers? [henninge,allenap]
- Proposed coding standard for YUI modules. [Edwin]
I think a file such as lib/canonical/launchpad/javascript/registry/timeline.js should define its module like this:
YUI().add('registry.timeline', function (Y) { var module = Y.namespace('registry.timeline'); module.someFunction = function() {}; });
Then, the code could be accessed with:
YUI().use('registry.timeline', function(Y) { Y.registry.timeline.someFunction(); });
The javascript style guide doesn't specify how modules should be named currently.
Cleaning up outstanding approved branches on +activereviews, bac
your item [your name]
Rejected items